Expand all | Collapse all

Segmentation Fault - AWS AMI Python JDBC

  • 1.  Segmentation Fault - AWS AMI Python JDBC

    Posted 06-23-2017 12:41

    I am running MapD within AWS from the MapD AMI. I have my data loaded and am building a python application which utilizes the Python Client JDBC method to query my data. As of last week everything was working fine; i was successfully querying and displaying data from the AWS database within development on my local machine. I resumed development today and now i receive a “Segmentation Fault (core dumped)” print whenever the JDBC query is attempted (at the ‘jaydebeapi.connect(…)’ line). My coworker is getting the same error so I know it is not my machine specifically. Immerse still is behaving normally. It really blows my mind that this is happening out of nowhere. I don’t know Java and Googling any info on Segmentation Faults doesn’t have enough information about a cause which my simple knowledge can understand…

  • 2.  RE: Segmentation Fault - AWS AMI Python JDBC

    Posted 06-23-2017 13:40


    See pinned thread SEGFAULT due to new glibc

    Assuming you are using the Community edition you will need to get the new version.


  • 3.  RE: Segmentation Fault - AWS AMI Python JDBC

    Posted 06-23-2017 14:16

    This is related to the Stack Clash kernel fixes pushed out by most distros earlier this week. As a temporary workaround, could you try increasing the Java stack size:

    export JAVA_TOOL_OPTIONS=-Xss1280k

    It sounds like there will be another round of kernel updates coming out soon which should hopefully resolve this issue - it affects most programs which use JNI, including large projects such as Eclipse.

  • 4.  RE: Segmentation Fault - AWS AMI Python JDBC

    Posted 06-26-2017 11:01

    so i downloaded the new version tar and upgraded it on the server following these instructions https://www.mapd.com/docs/latest/getting-started/upgrading/
    since it is the AWS AMI and no MAPD_PATH is declared, i could only deduce the mapd path to be /raidStorage/prod/mapd/

    i followed the instructions and everything seemed to have upgraded okay. immerse is working (faster than ever) and i can retrieve all my data but i was still getting the Segmentation fault (core dumped) response. so the cause of the issue doesn’t seem completely resolved by the upgrade?

    i followed andrew’s temp workaround and added the environment variable to my local machine. this solved the issue! (thanks andrew!) i recognize this is only a temporary fix but at least i can continue developing in the meantime. wanted to post my results here in case anyone else out there was curious.

    thanks dwayne and andrew for your quick help!

  • 5.  RE: Segmentation Fault - AWS AMI Python JDBC

    Posted 06-26-2017 13:24


    Glad it got you going again.

    The MapD fix resolved the segfault from within the MapD code with the new glibc and JNI.

    Andrews fix works around the issue for python (which we cant fix in our code).

    So the behavior you experienced is expected.

    thanks for update