Discussions

Expand all | Collapse all

Geo Point Map Multiple Layers not working.

  • 1.  Geo Point Map Multiple Layers not working.

    Posted 12-03-2019 16:36
      |   view attached
    Hi,

    I am unable to use multiple layers with the Geo Point Map in Immerse. I am tried multiple datasets but getting the same error. I get the following error message:
    "Exception: Not enough OpenGL memory to render the query results".
    Therefore, I searched the Omnisci Community Forum for the answer and got this question / answer. As suggested in this answer, I tried to increase the Open GL memory by editing the "Omnisci.conf" file in $OMNISCI_STORAGE with the following line
    render-mem-bytes = 9000000000
    So I kept on increasing the memory to 1GB, 2GB, 4GB, 9GB. and restarting the omnisci_server and omnisci_web_server with the commands sudo systemctl start mapd_server and sudo systemctl start mapd_web_server. But the problem is still remaining. Kindly find the attached image when I used the flights_2008_10k dataset. 

    If you need anything else, please let me know. 

    Thanks and kind regards



    #Immerse


  • 2.  RE: Geo Point Map Multiple Layers not working.

    Posted 12-04-2019 03:48

    Hi @Muhammad Bilal Saleem,

    My best guess is you are facing an issue, but I am not sure you are restarting the server, after changing the parameter (you should use something like sudo service omnisci_server restart).

    I reproduced your issue and looking at the server logs I got this error message

    2019-12-04T12:09:00.142478 E 4198 RenderAllocator.cpp:37 Not enough buffer memory on device id 0 to render the query results. Render buffer size: 500000000 bytes. Requested size: 640000000 bytes.
    2019-12-04T12:09:00.142822 E 4198 RelAlgExecutor.cpp:2278 Query execution failed with error Not enough OpenGL memory to render the query results

    The system is allocating enough memory to render the Number of Points specified in the Immerse interface (10M is the default) regardless of the number of records of the table (10K)

    To make your dashboard works, you can increase the render-mem-bytes parameter, or you can decrease the maximum number of points Immerse is going to render



    To be sure that the parameter is changed, check into the log file of the omnisci server, that's located in $OMNISCI_STORAGE/data/mapd_log/omnisci_server.INFO located near the start of the log file

    2019-12-04T12:08:53.415606 I 4198 EglPlatform.cpp:241 EGL Version: 1.5
    2019-12-04T12:08:53.415684 I 4198 OpenGLDriver.cpp:69 OpenGL Version: 4.6
    2019-12-04T12:08:53.443332 I 4198 EglPlatform.cpp:291 Found 2 valid Egl devices
    2019-12-04T12:08:53.443367 I 4198 EglPlatform.cpp:293 Cuda ID: 0 UUID: b3a74fb2-2742-8933-ca7f-fe9bf9ce7b7b
    2019-12-04T12:08:53.443373 I 4198 EglPlatform.cpp:293 Cuda ID: 1 UUID: 8f2f2a2c-ff95-d7ff-7baf-36f22bbbfd62
    2019-12-04T12:08:53.443383 I 4198 DriverInstance.cpp:47 Using GfxDriver: OpenGL
    2019-12-04T12:08:53.443477 I 4198 QueryRenderManager.cpp:88 QueryRenderManager initialized for rendering...
    2019-12-04T12:08:53.443484 I 4198 QueryRenderManager.cpp:89 Num GPUs to use 2
    2019-12-04T12:08:53.443489 I 4198 QueryRenderManager.cpp:90 Render Cache Limit 500
    2019-12-04T12:08:53.443493 I 4198 QueryRenderManager.cpp:91 Render Mem (bytes) 500000000
    2019-12-04T12:08:53.443497 I 4198 QueryRenderManager.cpp:92 Poly Cache (bytes) 300000000