Discussions

Expand all | Collapse all

omnisci_web_server service start fail, found "start-limit-hit" in log

  • 1.  omnisci_web_server service start fail, found "start-limit-hit" in log

    Posted 03-20-2019 08:39
    i got experience with MapD ver 3 before, and going back to OmniSci fresh install, finished all the steps, able to put demo data and queries.
    but when i tried to start immerse by "sudo service omnisci_web_server start" and then check service status, i got the fail reason "start-limit-hit"
    did some search but no clue. would be great if anybody can help.

    im using Ubuntu 16 LTE fresh new OS install, then follow steps to install OmniSci.

    thanks.

    ----
    user1@server1: ~$ sudo service omnisci_web_server status
    ● omnisci_web_server.service - OmniSci web server
    Loaded: loaded (/lib/systemd/system/omnisci_web_server.service; disabled; vendor preset: enabled)
    Active: failed (Result: start-limit-hit) since T4 2019-03-20 22:34:24 +07; 4s ago
    Process: 31280 ExecStart=/opt/omnisci/bin/omnisci_web_server --config /var/lib/omnisci/omnisci.conf (code=exited, st
    Main PID: 31280 (code=exited, status=1/FAILURE)

    Th03 20 22:34:24 server1 systemd[1]: omnisci_web_server.service: Unit entered failed state.
    Th03 20 22:34:24 server1 systemd[1]: omnisci_web_server.service: Failed with result 'exit-code'.
    Th03 20 22:34:24 server1 systemd[1]: omnisci_web_server.service: Service hold-off time over, scheduling re
    Th03 20 22:34:24 server1 systemd[1]: Stopped OmniSci web server.
    Th03 20 22:34:24 server1 systemd[1]: omnisci_web_server.service: Start request repeated too quickly.
    Th03 20 22:34:24 server1 systemd[1]: Failed to start OmniSci web server.
    Th03 20 22:34:24 server1 systemd[1]: omnisci_web_server.service: Unit entered failed state.
    Th03 20 22:34:24 server1 systemd[1]: omnisci_web_server.service: Failed with result 'start-limit-hit'.
    -----

     File: /var/lib/omnisci/omnisci.conf

    port = 6274
    http-port = 6278
    calcite-port = 6279
    data = "/var/lib/omnisci/data"
    null-div-by-zero = true

    [web]
    port = 6273
    frontend = "/opt/omnisci/frontend"
    servers-json = "/var/lib/omnisci/servers.json"
    enable-https = true
    -----
    #Immerse

    ------------------------------
    Anh Pham
    Managing director
    Briz informatics
    Binh Duong
    918839284
    ------------------------------


  • 2.  RE: omnisci_web_server service start fail, found "start-limit-hit" in log

    Posted 03-21-2019 04:29
    Edited by Candido Dessanti 03-21-2019 04:32
    On ubuntu18.04 works flawlessly, but I can check on ubuntu 16 later in the day.

    Are sure the problem isn't in the JSON config?

    Anyway, in the OS version of the software, the web server isn't useful; Immerse is not included anymore

    ------------------------------
    Candido Dessanti
    Dba
    Crismatica consulting
    Rome
    ------------------------------