Discussions

Expand all | Collapse all

Setting Up Enterprise Edition on AWS

  • 1.  Setting Up Enterprise Edition on AWS

    Posted 6 days ago
    I am setting up a new Enterprise Edition (no previous license included) on an AWS account. Following directions here (https://docs.omnisci.com/latest/4_get_started_aws_ami.html) and selected this version of OmniSci (https://aws.amazon.com/marketplace/pp/B0727Q5ZLX?ref_=aws-mp-console-subscription-detail#pdp-reviews). 

    Following the directions, my EC2 instance spins up. When I go to connect to OmniSci Immerse, I actually have to visit port 6273, NOT 8443 as specified in the directions. Furthermore, once I access OmniSci Immerse, It prompts me for A username, password, and database. No combination of usernames (MapD, admin) or passwords (Instance ID) allow me to log in to OmniSci Immerse. As soon as the page loads, there are red error letters "Connection error when fetching license". 

    I've emailed the sales team at OmniSci but have not heard back from them after several days. Please help!

    Thanks!​
    #Core

    ------------------------------
    Sammy H.
    ------------------------------


  • 2.  RE: Setting Up Enterprise Edition on AWS

    Posted 5 days ago
    Hi @Samantha Hamilton,

    when you run an Enterprise Edition without licence, at login you should get a screen like that



    where you asked to enter a licence key. You can ask a 30 day trial licence following this link omnisci enterprise trial.

    while reading the instructions the ports indicated seems to be the correct one (6273 for immerse web server) and give the idea you need to ask a trial licence to activate it. Have you created a 5.0.1 version of AMI?



    Try this path while I'll ask internally if this is the right one. If you are unable to enter the tri licence, you should try to rename a possibly outdated licence file renaming it  and restarting the services; the file is located in /var/lib/omnisci and it's called omnisci.licence







  • 3.  RE: Setting Up Enterprise Edition on AWS

    Posted 5 days ago
    Hi @Candido Dessanti,

    This is not the screen that I see then I run the Enterprise Edition - not the Enterprise Edition BYOL. To be clear, I'm running it entirely on an EC2 instance on AWS. I will attach a screenshot ​this afternoon as to what my login screen looks like, but there is no location to enter a license key. 

    It was my understanding that the standard AWS Enterprise Edition has a 30 day free trial that has a license key built in, and that the AWS Enterprise Edition BYOL is where you bring a license key and enter it upon login. Please reference this link (https://aws.amazon.com/marketplace/seller-profile?id=f9f40dff-9943-4d95-8437-8414612724c6) to view the different versions of OmniSci available on the AWS Marketplace. 

    Can you send me a link to the instructions you are following? It would be very helpful to me. Thanks!



  • 4.  RE: Setting Up Enterprise Edition on AWS

    Posted 5 days ago
    Edited by Candido Dessanti 5 days ago
    Hi @Samantha Hamilton,


    I posted the instructions of the OmniSci Free Trial instance​, and it's stated that you have to enter a licence;I'm not sure if there is a problem on AMI and/or the instructions are outdated. I tried to give you the instructions to speed-up up your evaluation process, while trying to sorting out any problem that occurred to your AWS instance.

    the link to the usage is the following https://aws.amazon.com/marketplace/pp/B0727Q5ZLX?qid=1579006549506&sr=0-3&ref_=srh_res_product_title#pdp-usage




  • 5.  RE: Setting Up Enterprise Edition on AWS

    Posted 5 days ago
    Just an  idea. have you opened the ports from 6273 thru the 6279 on your AWS's instance?

    I think your browser needs to connect directly to the database server that's listening on 6274 port.


  • 6.  RE: Setting Up Enterprise Edition on AWS

    Posted 4 days ago
    I talked internally, and it looks there is a problem on our AMI. A fix is under works and should land in a day or two