Cannot configure dashbroard

Hello,

I followed the instructions here Configuring a Dashboard - OmniSci Docs , but I cannot see the configuration icon, and it was not disabled. Can someone help me? as I need to configure the dashboard to change the axis label fonts and such.
Thank you.

I originally posted my issue in Github omnisci board, Cannot see dashboard configuration with admin account · Issue #685 · omnisci/omniscidb · GitHub .
Please see to see what I tried so far.
I appreciate any help

Hi,

Can you post a screenshot?
Can you share with use the servers.json file that’s in use, to confirm that’s the menu it’s not disabled for regular users?

Ofcourse!

Can you help me identify find the server.json? Also, just making sure you helped me originally in the github thread right?

Hi,

Well, your screenshots have very strange elements, that I have never seen on Immerse before. The two x and the two empty containers are a premiere.

Anyway, the server.json file is an optional file and you can call it with the name you prefer, and to know if it’s used or not, and how it’s called you have to open the omnisci.conf file in the server where the database and the webserver are installed; so in your case, connect with ssh to the 10.206.203.xxx server, using a Linux account, possibly with elevated privileges, then type

find / -name omnisci.conf

if your installation is using the defaults you should get an output like this


/var/lib/omnisci/data/omnisci.conf

then

cat /var/lib/omnisci/data/omnisci.conf
port = 6274
http-port = 6278
calcite-port = 6279
data = "/mapd_storage/data_test"
null-div-by-zero = true
renderer-use-vulkan-driver=false

[web]
port = 6273
frontend = "/opt/mapd/omnisci-ee-5.8.0-20211011-b40c4f681d-Linux-x86_64-render/frontend"
server-json = "/mapd_storage/data_test/servers.json"

if the parameter server.json exists, you can find where the server.json file is located.

if you haven’t the privileges to do that, ask to a system administrator of your university to check if the server.json exists and how is configured.

Candido

I can do it on Monday and I will update you then.

Thank you!

I don’t think we have it set up, this is the output we got.

(base) gkim50@en4115285ul:/var/lib/omnisci$ cat omnisci.conf
port = 6274
http-port = 6278
calcite-port = 6279
data = "/var/lib/omnisci/data"
null-div-by-zero = true

[web]
port = 6273
frontend = "/opt/omnisci/frontend"
render-mem-bytes = 500000000
(base) gkim50@en4115285ul:/var/lib/omnisci$

Can you help me see how to set it up?

Thank you.

I still need help if anyone can assist.
Thank you

Hi,

Yes, the server-JSON is not configured, so every user in the database is able to access to dashboard customization; as I already said in the first post your image looks weird, we already tried accessing to my system, so it looks that your client is ok.
Are other users besides you having the same problem? You could try to create a new user in the database and check if the problems are similar, or you could ask to a colleague of you to access with your credential to Immerse.

Regards,
Candido

p.s. sorry for the late reply but I didn’t see your message