Cannot run Mapd in AWS - Invalid http response


I got my EC2 instance up. In browser, https://<public_dns>:8443 gives me invalid http response.

I can’t get to port 8443 per following instructions. So what do I have to do once I get my EC2 running?

MapD DB & Visual Analytics Platform Usage Instructions for MapD Database & Visual Analytics Platform (Community Edition)
Access the application via a browser at https://<public_dns>:8443. Username is mapd, password will be the same as the instance-id. To connect to the operating system, use SSH and the username centos. The SQL CLI mapdql may be accessed by connecting to the instance via SSH and then running: /raidStorage/prod/mapd/bin/mapdql -u mapd -p {instance-id}


@kctung can you get to any other services on any other ports?


How would I test it?

I expect to just put ipv4 ip address issued by my EC in the browser, follow by port number 8443. Is there more to it than this?


have you authorized your ip to access the 8443 port on AWS virtual machine in AWS console?

I tried a default config (with the cert generated by mapd software itself) on a on-premise installation and i havent any problems with the latest versions of browsers.


Still doesn’t work. I designated Custom TCP port 8443 to be for everywhere. p2.8xlarge instance is running.

I was able to connect to the database:
/raidStorage/prod/mapd/bin/mapdql -u mapd -p



maybe the problem il Chrome browser

it’s worth a try with Firefox or another browser (i am sorry but at the moment i cannot check on my system)


I tried Firefox. it doesn’t work either.

Is there anything that I overlooked? I’d really appreciate any help here.


Hi @kctung -

From the AMI image CLI, do you get a response from running:

curl --insecure https://localhost:8443


I think curl is fine:

[centos@ip-172-31-23-134 ~]$ curl --insecure https://localhost:8443
<!doctype html>

MapD Immerse


But I just can’t get any browser to work. This is Firefox:

Screen Shot 2018-06-06 at 4.20.18 PM



Repost my curl output:


Since Immerse is accessible within the VM, the problem must be a networking issue. Is it possible to allow all traffic from the internet on all ports? If that works, then you can selectively add the rules back to the firewall to secure your instance.


are you sure you are calling with https protocol? looks you are using http protocol to call

here is my screenshot with chrome using http on browser side

with https it works

with firefox using http


using https of course works


Thanks everyone! I finally got in!