Can't build from sources (MacOS Sierra 10.12.6)


Trying to build mapd-core from github

$ sh
$ cd build; cmake -DCMAKE_BUILD_TYPE=debug -DENABLE_CUDA=off ..
$ make -j 4

gives me the following error

In file included from /Users/xxx/work/repos/mapd-core/ThriftHandler/MapDHandler.h:53:
/Users/xxx/work/repos/mapd-core/QueryEngine/Execute.h:127:26: error: no member named 'getArgumentList' in 'llvm::Function'
  auto& arg_list = func->getArgumentList();
                   ~~~~  ^
1 error generated.
make[2]: *** [ThriftHandler/CMakeFiles/thrift_handler.dir/MapDHandler.cpp.o] Error 1
make[1]: *** [ThriftHandler/CMakeFiles/thrift_handler.dir/all] Error 2

What could be the reason?

I tried to downgrade xcode

$ clang --version
Apple LLVM version 8.0.0 (clang-800.0.42.1)
Target: x86_64-apple-darwin16.7.0


Sorry for the issues. The problem is that the script was set to install the latest version of LLVM, which is not yet supported by mapd-core (LLVM’s APIs frequently change between versions, which makes it a bit of a struggle to maintain a codebase which supports multiple versions). For more details see Mac os Sierra(2015 MacBook Pro 10.12 with Nvidia GPU) successfully working .

I just pushed some small updates to the script which might help a bit. Could you try uninstalling LLVM, pulling the latest version of the script, and try re-running it? You may wish to comment out the CUDA section in order to speed things up.

brew uninstall llvm
git pull
# edit mapd-deps-osx, commenting out CUDA lines ~30-34
bash ./


Thanks, Andrew! Solved.