Community Edtion on AWS P2 Instance fails to launch


I subscribed to Mapd Community edition on AWS Marketplace and launched the P2 Large Instance. It says it is launching in the background but when i go into my ec2 Console there is nothing there. I launched twice and nothing. Does anyone have any insight?

How do I install MapD?


Thanks for giving MapD a trial run.

I have seen cases like this where your amazon limits restrict the machine types you are trying to start. When this happens, normally you see a instance in terminated state with a message saying you have exceeded your limits for whatever item it was not allowed to use.

Other than that I would suggest trying doing the start from a ‘Manual Launch’ option from the market place to see if you see any further detailed failure information. I have just tried launching both on the Oregon and Ohio region, one with “one click” and one “manual” and they both worked for me. Small consolation or you :slight_smile: \

Let us know what you see?


Thanks, I’ll give it another try. Destiny is no matter of chance. It is a matter of choice. It is not a thing to be waited for, it is a thing to be achieved.
William Jennings Bryan


So I Manually Launched and got the error that I have exceeded my ec2 limit. I went and checked the limit for a P2 machine and it was 0 ???. I’m requesting a limit upgrade. I should be good from here. Thanks.


I’m up and running now.Thanks.


I’m confused about MapD on AWS. I am connected to my ec2 instance but I’m not clear on where I start. Is Mapd fully configured and ready to run or do I need to configure it and if so where do I start.



By default the community edition starts up a small database with some data in it.

The Immerse tool will be available at https://<your aws ip>:8443

You will have to make sure you allow inbound connection to 8443 in the security group you started the instance in.

The password is the instance-id of your AWS instance.

From the shell on the instance you can interact with the database via mapdql