Community version doesn't support data import?


#1

Hi,
I am using the dockerized community version. I’ve tried importing data using Data Manager tool in Immerse, but have been unsuccessful. Preview showed many records, but the created table always showed zero rows. I just want to know if the docker CE version allows data import from local file?


#2

@nhonaitran yes, the Docker CE version does allow data import. Can you tell us more about the data itself? What version of CE are you using?


#3

Hi @nhonaitran,

First try to load just a few rows from your data set to make sure that it gets saved in the created table. Now by loading the whole data set if you see zero rows then it points to an inconsistent dataset, for example, a whole bunch of rows with extra columns. You can look at the mapd-storage/data/mapd_log/mapd_server.INFO file for the cause of failure.

Regards,
Veda


#4

Hello @easy, my dataset contains key/value pairs, tab delimited entries. For example,
id 1 name apple price 1.99 on_sale 0
name pear price 0.95

Because the rows have jagged columns, the importer didn’t consider these rows to be valid, so it rejected all of them. That’s what I gather from reviewing the docker log.


#5

I tried your suggestion to load a few rows and it worked fine. Thank you for the suggestion to look at the mapd_server.INFO file. It is very helpful.