Connect to Immerse through web failing


I have a MapD server running in an Amazon EC2 Redhat 7.3 machine in a g2.2xlarge GPU instance. From the screen shot below, it can be seen that I am able to insert data and perform query through mapdql.

However, I have been unable to connect to immerse through my web browser. I attach another image with my port inbound rules for the Redhat instance. When I try to connect through it is giving me ERR_CONNECTION_RESET in chrome. I believe I have successfully configured the dynamic port forwarding because I have been using the MapD community edition Amazon AMI before. The blurred portion in the image below is my laptop ip.



Did you try the response to your previous same question

Please share the URL you are trying to connect to

Are you definitely trying to connect with HTTPS:// protocol?



Yes, I am using HTTPS: for connection. Yes, I was able to connect through port 8443 to the MapD community edition AWS AMI. Now, I am trying to connect to another MapD server running on a Redhat OS in AWS instance. This is not the AMI provided by MapD. Should I use the same 8443 port for this one as well?



If this is not the AMI then we will need to know more about your config.

In your mapd.conf file what port are you exposing mapd_web_sever on, by default it is 9092 and it is HTTP only?

So if you have changed no other config and done a standard install you should try


Do you have the local firewall still enabled on your redhat install? Is so, you need to make sure that you open the appropriate ports there as well? Normally done via a command like

sudo firewall-cmd --zone=public --add-port=9092/tcp --permanent

sudo firewall-cmd --reload



Additionally it looks like you’re running driver version 367.57, which is not supported. While MapD will run on the older drivers, certain features such as rendering may be disabled.


Yes I have done that. You can see in the first screen shot I have the output of that command. I also ran sudo firewall-cmd --reload and got “success” as output. Afterwards when I try to open the browser and cannot connect to immerse. I have not changed anything in the mapd.conf file. I am following the default options.


So I guess it is coming from the unsupported nvidia driver which means one cannot run MapD in g2.2xlarge clusters with GRID K520 gpus. Thank you for the information.



The older driver will not stop you from connecting to immerse




How are you starting MapD

i do not see any sign of mapd_web_server running in your screen shots?



I ran sudo systemctl start mapd_server and sudo systemctl start mapd_web_server. Do I need to do anything else. I followed this instructions provided for CentOS installation from MapD website.


Do I need to install thrift in order to make the web_server run?


On the instance itself, could you run the following:

sudo systemctl status mapd_web_server


curl http://localhost:9092

The first will tell you if the web server is running, the second will let you verify that it can at least be accessed locally, without any firewalls.

(You may need to sudo yum install curl if it isn’t installed).


It says connection refused when I ran curl http://localhost:9092. Here are the details

$ sudo systemctl status mapd_web_server
● mapd_web_server.service - MapD web server
Loaded: loaded (/usr/lib/systemd/system/mapd_web_server.service; enabled; vendor preset: disabled)
Active: failed (Result: start-limit) since Fri 2017-07-07 15:35:52 EDT; 23s ago
Process: 1815 ExecStart=/home/ec2-user/mapd-core/bin/mapd_web_server --config /var/lib/mapd/mapd.conf (code=exited, status=203/EXEC)
Main PID: 1815 (code=exited, status=203/EXEC)

Jul 07 15:35:52 systemd[1]: Unit mapd_web_server.service entered failed state.
Jul 07 15:35:52 systemd[1]: mapd_web_server.service failed.
Jul 07 15:35:52 systemd[1]: mapd_web_server.service holdoff time over, scheduling restart.
Jul 07 15:35:52 systemd[1]: start request repeated too quickly for mapd_web_server.service
Jul 07 15:35:52 systemd[1]: Failed to start MapD web server.
Jul 07 15:35:52 systemd[1]: Unit mapd_web_server.service entered failed state.
Jul 07 15:35:52 systemd[1]: mapd_web_server.service failed.

curl http://localhost:9092
curl: (7) Failed connect to localhost:9092; Connection refused



If this is an OS build did you select to download the Immerse frontend code. It may be that you do not have the immerse code downloaded. Please check you have a frontend directory and that it has content.




please run this command

/home/ec2-user/mapd-core/bin/mapd_web_server --config /var/lib/mapd/mapd.conf

from the command line



Thank you for your support. I truly appreciate your help. When I run /bin/mapd_web_server --config /var/lib/mapd/mapd.conf the cursor sits there indefinitely without coming back to allow me run any other command in the shell. I have a frontend folder in my mapd-core folder. The content of the folder and the output of the mapd_web_server --config command can be seen in the following screen shot

From the screenshot you can see at the bottom that the cursor did not return anything. It has fallen into sort of an infinite loop.



It now means the web server is running. I would not expect the cursor to come back at this point.

try connecting now.




i suspect the 203 error you are seeing when trying to run mapd_web_server from systemd is some kind of permissions issue.

Please confirm the user that you identified as the user to run the mapd services when setting up systemd definately has execute access to all the binaries and read and write to the data directory.



Thank you I have been able to connect to the MapD Immerse. I was getting some sort of connection refusal through thrift when I tried to run the mapd_web_server from systemd. However, now I can connect to Immerse. Did not use the systemd inorder to make MapD running. Followed your replies to my questions in this thread. Thanks again.


I am trying to import a map of usa with shp, shx and dfp file through MapD Immerse. I have been able to load the files from my local computer to immerse. However, in the final step when I hit ‘import files’ I get an error from Mapd saying “File does not exist: data/mapd_import/hwJnchLyOFLfOjUFNDV85K0svabQZRUK/cb_2016_us_county_20m.shp”. Although in the data folder in mapd server location when I do an ‘ls’ I can see all these files. Do I need to enable some file permission issue here.