Dict Encoded String Query


In the SQL Editor I’m trying to run a simple command (select * from table where uid=‘slnfdln320fjes’) however, this returns a success of 0 rows which doesn’t make sense because I ran (select * from table) and copied that uid from the result of 2000 rows.
I did the same commands with another table in my database and it worked.
The only difference is that the type of column may be different (dict encoded str v str) but I couldn’t check that because I’m not sure which command to use (tried NFORMATION_SCHEMA.COLUMNS and sys.columns).

So 2 questions I guess:
How do you check the attribute type using the SQL Editor?
Is there a reason my command won’t return a row? Does it have to do with it being a dict encoded str?

Thank you,


With mapdql you can check the data types of all columns typing \d name_of_table


Hey aznable,

Thank you for your response! So does mapdql imply I need to actually ssh into the database and type that command? At the moment, I’m trying the command you suggested (\d Data_Table) in the SQL Editor and getting this error:
Exception: Parse failed: Lexical error at line 1, column 1. Encountered: "\\" (92), after : ""



Mapdql is installed with mapd so you have to log-in to host where mapd is installed (ssh or telnet…it depends wi8tch services the host is exposing). Anyway installing mapd-core or copying the mapdql exec and dependencies needed on another host would make you able to use it wihtout having full access host where mapd is installed ,

with sqleditor provided with immerse we are not able to use \ commands,now, and we are resticted to see just generic type of column. i guess the tool in intendeed for business/basic users


Okay yeah I’m familiar with mapdql.
Thanks for the heads up about sqleditor