Error uploading CSV to OmniSci Immerse


#1

hey OmniSci community,

I’m new to OmniSci and have a question about using the Import Data function in Immerse. I have a 2gb CSV which uploads successfully in one environment but not in the other. What can be the issue? The error I get is, “Server responded with 0 code”. Should I be looking at server side settings? Not really sure what to do, would appreciate it if someone can point me in the right direction.

FYI, I am aware that I can ZIP the CSV and import that way. That’s what I’m doing now but was curious why the CSV if failing to upload.

Thanks!


#2

@SyedMohsinHasan welcome to OmniSci and we’re happy to try and help. That error isn’t unique to us; it’s a common error message for timeout when uploading a file, but it’s probably still something in the environment.

First, can you tell me about the two different environments? Are they running locally, in OmniSci Cloud, from machine images? Are there any obvious differences between the two?


#3

hey @easy, thanks for the response!

I don’t know too much about the environments. Both environments are RHEL7 servers and MapD was installed and set-up, by someone else, the exact same way. Is there a MapD timeout setting I should be looking for? I don’t think there’s anything like that in the mapd.conf file, but I could be wrong. Do you know if the Import Table function generates any logs? I can look for those.


#4

OK, sounds like they’re running on local machines, so probably Community Edition downloaded from our site.

Can you get to mapd/data/logs and see if you can find that error?
We can also walk through changing the level of logging if needed, but I bet that error is present at the normal level of logging.


#5

@SyedMohsinHasan we’ve seen this error a few times in Cloud instances and cannot reproduce it, so we’re pretty keen to see if your logs or environmental variables shed any light.


#6

Hi @SyedMohsinHasan any chance you were using a proxy when uploading data? An issue with a proxy disconnecting and connecting could lead to this error condition.


#7

I think I have isolated the issue. So while the CSV is uploading, I’m seeing the mapd user write to the /tmp directory on the server. Unfortunately there isn’t enough space in the /tmp directory so that’s why it fails. It was running for a long time so I just cancelled the upload, that’s why I wasn’t able to see if the log file displays any errors. Do you know if this is a server setting or a mapd setting?

I think I have enough information to forward to my server POC so they can investigate. If i can just redirect the directory during upload then I think that will solve the problem.


#8

The files uploaded with immerse are inherently temporary so I guess you can change the enviroment variables $temp, $tmpdir or whatever your OS is using for the user running the omnisci software


#9

mapd_web_server has an option --tmpdir to change the default temp file location. If starting with systemd, add it under the [web] section:

[web]
tmpdir = "/path/with/more/free/space"

(it also respects the TMPDIR env var mentioned by @aznable above)