First time user - mapd-ce aws ami instance not accessible


#1

Hi - I am able to start an EC p2.xlarge instance running the mapd-ce version (mapd-ce-4.0.2-3-1e20d964-1d79-4290-9751-5af45b74f67b-ami-8bb487f4.4 (ami-070477b91ec2d49bf) -

I have configured the aws network security group as per your recommendation (tcp 22, 8443, 9100 open to world)

however

  1. I am unable to ssh into the server using ssh -i ~/.ssh/my.pem centos@myinstancepublicservername.amazonaws.com - I get
    Permission denied (publickey,gssapi-keyex,gssapi-with-mic)

  2. I am unable to login to http://myinstancepublicservername.amazonaws.com:8443
    The login page is served BUT when I provide the aws instance as the password, I am unable to login - and see the error message:
    “has_object_privilege” (using Chrome browser)

I also tried Microsoft Edge browser - but that also failed

I have tried this on personal aws account AND office aws account - get same failures


#2

just tried the pro version (non-community) version - same https login and ssh login issue -

(aws ami version - mapd-ee-4.0.2-3-8ef4c5da-0daa-46cd-aa88-315bdaf7eef1-ami-bec6f5c1.4 (ami-0c242773) )


#3

For ssh try with ssh mapd@yourawsmachine and enter the password provided

To access database from immerse, click on advanced setting to verify the port you opened is the right one.


#4

what password provided? The Ami usage instructions clearly state login as centos @


#5

So i tried logging in ssh -i mypemfile.pem mapd@awsserver - permission denied
Webpage login failed with same error above
I should also point out that the aws machine console is blank for this started up image


#6

maybe you having a problem with the key pair, now I’m trying by myself.
Anyway the right port for the database would be the 9091 not the 9100


#7

Ok, I believe both the ce- and pro versions of you Ami are un-ssh able. He tried with different aws accounts (work and home) - and on boot of you Ami the machine console is blank

I tried to build my own Ami based on centos - but this turns into a nightmare given that some of the dependencies that cuda needs have been removed from centos/rhel 7.5

So I switched to creating my own Ami based on Ubuntu 18.04 and followed the instructions on setting that up on your site. That worked in minutes. So I suggest you create new Amis based on ubuntu


#8

Hi @pbirnie,

you can log into the centos machine with ssh using the ec2-user and the pem file you have associated to the instance.

so you have to ssh ec2-user@yourinstance -i yourpemfile.pem

If you want to log directly to mapd user on the operating system the fastest way is to launch those commands

sudo cd /home/ec2-user
sudo cp -r .ssh /home/mapd
sudo chown mapd:mapd /home/mapd/.ssh

or you can create the .ssh dir and adding the authorized_keys file with the private key generated with ssh-keygen command.

In the end looks like the docs provided for this ec2 are wrong because a user called centos doesn’t exists


#9

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)