Getting Started on AWS - MapD AMI


Hey! So i’m struggling to get started with MapD. I’ve been banging my head against the wall for 2 days straight now and it’s really getting me down because I feel like it shouldn’t be this difficult. The documentation has good step-by-step instructions but don’t seem to blatantly tell me the most rudimentary ideas… so I’ll list my questions here. Hopefully someone has been through this before, and if I’m not as alone as I feel I am maybe the documentation should be updated? I’m working within AWS as to let them handle the hardware.

  1. I started by spinning up a machine using the MapD AMI found here:
    I did so assuming that this AMI already has MapD installed and configured and ready to go. Is this correct? If so, I don’t have to run through the installation as outlined in the documentation? If so, where do I start looking at the documentation for guidance and instruction-- the Activation section?
    It has to be installed since i can ssh into the machine and run: /raidStorage/prod/mapd/bin/mapdql -u mapd -p {instance-id} to start running queries,… right?? Listing the tables from here tells me there is only 1 table by default: nyc_taxi_201512

  2. if utilizing this AMI does in fact have MapD pre-setup, the documentation is all relative to the idea that I had done the installation which makes working through the documentation extremely confusing. Things like none of the environment variables being the same and the installation being down in the raidStorage directory opposed to the user’s home directory.
    should my MAPD_PATH be /raidStorage/prod/mapd ???

  3. so I tried setting MAPD_PATH=/raidStorage/prod/mapd and ran the command to insert sample data but that failed too (despite the fact that /bin/mapdql does exist! i used it and cd’d to find ie!)

  4. the other thing that really confuses me is that I started mapd_server and mapd_web_server as per the Activation instructions but I cannot connect to Immerse through my web browser. My server is a in a public subnet with all ports open TCP both inbound and outbound.
    Type|Protocol|Port Range|Source
    All TCP|TCP|0 - 65535|
    All TCP|TCP|0 - 65535|::/0
    I try the url “” but only get “this site can’t be reached” errors. I also tried no port, 8443, 9091, and 9090. If MapD is installed with the taxi data, why can I not utilize Immerse?

  5. After running into all these brick walls I decided to un-intuitively assume the MapD AMI doesn’t have MapD preinstalled and setup to go. I started going through the installation instructions only to run into a whole slew of other issues so now I’ve backpeddled and come here with my tail between my legs, desperate for some guidance.

Please help!!



Thanks for looking into MapD.

Sorry for your confusion in trying to get this going.

From the AMI link you you shared, you will get a completely installed and running version of MapD.

You need to note a couple of things down from the EC2 console when your machine starts up

The two things you really need are

  1. The Instanceid, which you will use as your password
  2. The public IP of the running machine

This is mentioned in the Usage Instructions, also in the EC2 Console

In my case when I started up my instance I see

So to get to the Immerse console I would go to my browser and enter this URL

You will then see a message saying connection is not private as it is a self signed cert so you will need to accept this and add an exception in your browser (or replace the self signed certs with your organizations real certs)

Once you get through this you will reach the Immerse login screen

Enter the instanceid you noted down earlier, in my case i-0204ca88fba4ef44a into the password and you will reach Saved Dashboards

Click on NYC Taxis Dec 2015

And explore.


MapD Community Edition Sign up in AWS Cloud is not working for me
Inbound rules for Immerse connection in MapD AWS AMI
Where is the mapdql documented?

works great! thanks so much!

I had originally tried the url with port 8443 just like you outlined but it would just download a file… when i added the secure https:// protocol it worked great.