Install NVIDIA Docker Runtime Ubuntu Hirsute 21.04 build

Hello,
I’m following instructions from:

but while using curl to add the gpg key I get:

D16-WS:/opt/omnisci$ curl -s -L https://nvidia.github.io/nvidia-container-runtime/gpgkey|sudo apt-key add - distribution=$(. /etc/os-release;echo $ID$VERSION_ID)
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
gpg: can't open 'distribution=ubuntu21.04': No such file or directory

In fact, there isn’t any 21.04 distribution available :

How can I (if possible) still proceed to install docker and JupyterLab to Ubuntu Hirsute 21.04?

Hi,

Have you tried using Ubuntu 20.04 instead of the real os version?

curl -s -L https://nvidia.github.io/nvidia-container-runtime/gpgkey|sudo apt-key add - distribution=ubuntu20.04

Yes, already tried but got :slight_smile:

Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
gpg: can't open 'distribution=ubuntu20.04': No such file or directory

I think you shuold run

curl -s -L https://nvidia.github.io/nvidia-container-runtime/gpgkey|sudo apt-key add -

then

distribution=ubuntu20.04

and then the other commands

and hope that the 20.04 distribution will work in 21.04

Thank you,
that was an error.
Now, I completed the installation steps, but after executed:

sudo docker run --runtime=nvidia --rm nvidia/cuda:10.0-runtime-ubuntu18.04 nvidia-smi

I got :

Unable to find image ‘nvidia/cuda:10.0-runtime-ubuntu18.04’ locally
10.0-runtime-ubuntu18.04: Pulling from nvidia/cuda
e4ca327ec0e7: Pull complete
6b1dcaebb9a8: Pull complete
9ccfb664e116: Pull complete
10acf1d5627c: Pull complete
2096ab76e7d5: Pull complete
5c92358697be: Pull complete
c07fcf901eee: Pull complete
Digest: sha256:776e84da45abfe7932b6be3a8951295f29d40902fe5162c5e079339292c86906
Status: Downloaded newer image for nvidia/cuda:10.0-runtime-ubuntu18.04

and then :

/var/lib/omnisci$ sudo docker run --runtime=nvidia --rm nvidia/cuda:10.0-runtime-ubuntu18.04 nvidia-smiFri Oct 22 15:16:17 2021       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 470.63.01    Driver Version: 470.63.01    CUDA Version: 11.4     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0  On |                  N/A |
| 26%   45C    P8    10W / 180W |    802MiB /  8085MiB |      3%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
+-----------------------------------------------------------------------------+

So, the image downloaded is ubuntu18.04, and omnisci is not being loaded. Of course I cannot reach Immerse, neither.

Is it normal pulling an ubuntu18.04 instance at this point?

1 Like

Well,
I am not sure to let me check the docs about syntax

Hi @Gianfranco_Campana,

yes, it looks like it’s normal because for the ubuntu 20.04 distribution Nvidia is using the 18.04 Debian packages

candido@zion-legion:~$ curl -s -L https://nvidia.github.io/nvidia-container-runtime/$distribution/nvidia-container-runtime.list | \
>   sudo tee /etc/apt/sources.list.d/nvidia-container-runtime.list
deb https://nvidia.github.io/libnvidia-container/stable/ubuntu18.04/$(ARCH) /
#deb https://nvidia.github.io/libnvidia-container/experimental/ubuntu18.04/$(ARCH) /
deb https://nvidia.github.io/nvidia-container-runtime/stable/ubuntu18.04/$(ARCH) /
#deb https://nvidia.github.io/nvidia-container-runtime/experimental/ubuntu18.04/$(ARCH) /

after you run the Nvidia-container is expected that you haven’t omnisci running because you need to install additional dockers

candido@zion-legion:~$ sudo docker run --runtime=nvidia \
>   -d --runtime=nvidia \
>   -v /var/lib/omnisci:/omnisci-storage \
>   -p 6273-6280:6273-6280 \
>   omnisci/omnisci-ee-cuda:latest
Unable to find image 'omnisci/omnisci-ee-cuda:latest' locally
latest: Pulling from omnisci/omnisci-ee-cuda
171857c49d0f: Pull complete 
419640447d26: Pull complete 
61e52f862619: Pull complete 
2a93278deddf: Pull complete 
c9f080049843: Pull complete 
8189556b2329: Pull complete 
c306a0c97a55: Pull complete 
4eeefb9caa0a: Pull complete 
8bcffc4ca3eb: Pull complete 
0306005e1055: Pull complete 
0a41ac2096c9: Pull complete 
86629583cf47: Pull complete 
79ef4ecbf7bc: Pull complete 
8198d498df91: Pull complete 
ec3c4fd994d9: Pull complete 
Digest: sha256:fd16a83a562229d2b253546b4d6f523416e71d3baf5afcfc33b19b54d30a8057
Status: Downloaded newer image for omnisci/omnisci-ee-cuda:latest
64c677285e0deda8e2f6d16076a58caef7919c884a10ee704abf0903331d88fa

Assuming that in the /var/lib/omnisci, you haven’t any omnisci.conf file that it’s likely to have wrong parameters like data and frontend, you should have everything running

if there is already a license into the directory, you would get the usual login form.

Regards,
Candido

Thank you,
therefore the installation steps I performed seem to be what expected: if so, I cannot explain why, performing the checkpoint below , I don’t see the omnisci instance in the docker nvidia-smi output :

This is my output, instead:

In addition, when I execute:

docker run --rm nvidia/cudagl:11.0-runtime-ubuntu20.04 nvidia-smi

I find the omnisci instance in the local system :

WS:/etc/docker$ ps -ef|grep omnisci|grep -v grep
root       36794   36769  0 11:25 ?        00:00:00 /bin/sh -c /omnisci/startomnisci --non-interactive --data /omnisci-storage/data --config /omnisci-storage/omnisci.conf
root       36853   36794  0 11:25 ?        00:00:00 /bin/bash /omnisci/startomnisci --non-interactive --data /omnisci-storage/data --config /omnisci-storage/omnisci.conf
root       36858   36853  0 11:25 ?        00:00:00 /bin/bash /omnisci/scripts/inneromnisci --non-interactive --non-interactive --data /omnisci-storage/data --config /omnisci-storage/omnisci.conf
root       36863   36858  1 11:25 ?        00:00:27 ./bin/omnisci_server /omnisci-storage/data --port 6274 --http-port 6278 --calcite-port 6279
root       36864   36858  0 11:25 ?        00:00:03 ./bin/omnisci_web_server --port 6273 --backend-url http://localhost:6278 --data /omnisci-storage/data
root       36902   36863  0 11:26 ?        00:00:03 -Xmx1024m -DMAPD_LOG_DIR=/omnisci-storage/data -jar /omnisci/bin/calcite-1.0-SNAPSHOT-jar-with-dependencies.jar -e /omnisci/QueryEngine/ -d /omnisci-storage/data -p 6279 -m 6274 -T  -P  -Y  -Z  -c

Here I see multiple omnisci instances , one for the sh shell and one for the bash shell.

And also a new inneromnisci process that I don’t know what it is (it isn’t reported in the docs).

So, I don’t know if omnisci is starting with docker or not ( It is instantiated by the “docker run” command , but it is absent from the output of docker run nvidia-smi.

I can access Immerse regularly, but I’m not sure I could proceed to the jupyter installation without being confident on docker/omnisci one, before.

Currently I haven’t any omnisci.conf in /var/lib/omnisci.

Hi Gianfranco,

The only “real” processes started are the 36863 and 36864, the rest are scripts or whatever is needed to start the real processes.

About the first screenshot, you posted, I guess your output is the correct one. The step is needed just to confirm that the container can show the GPUs installed in your system.

I think you should proceed to install the Jupyter notebook. Just follow all the instructions to create the user with the correct role for Jupyter.

Candido

Hi Candido,
I followed the steps from:

after edited docker-compose.yml with:

jupyterlab-tmp:
    image: &jlabimage omnisci/omnisci-jupyterlab-cpu:v0.5

and also:

### Required settings ###

      DOCKER_JUPYTER_LAB_IMAGE: &jlabimage omnisci/omnisci-jupyterlab-cpu:v0.5

I get:

ERROR: yaml.composer.ComposerError: found duplicate anchor 'jlabimage'; first occurrence
  in "./docker-compose.yml", line 29, column 12
second occurrence
  in "./docker-compose.yml", line 53, column 33

pretty self-explanatory.

The first occurrence is related to point 10. of “Installing Jupyter with OmniSciDB” , while the second one is related to: “Upgrading docker-compose Services” paragraph.

Therefore I have to edit in this way:

DOCKER_JUPYTER_LAB_IMAGE: *jlabimage

in order to make the pull working.

In addition, if I stop my current active processes as in this note:

I don’t have any active omnisci instance, even after executing :

docker-compose up -d

while if I reactivate my omnisci local installation with:

sudo systemctl start omnisci_server
sudo systemctl start omnisci_web_server

I don’t have any Jupyter button in the top right corner of Immerse.

If I execute:

WS:/var/lib/omnisci$ docker container ls
CONTAINER ID   IMAGE                             COMMAND                  CREATED       STATUS                          PORTS      NAMES
8321529ce6fc   omnisci/omnisci-jupyterhub:v0.4   "/docker-entrypoint.…"   3 hours ago   Up 3 hours                      8000/tcp   jupyterhub
5e9e4414ae1a   omnisci/omnisci-ee-cuda:latest    "/bin/sh -c '/omnisc…"   3 hours ago   Restarting (1) 24 seconds ago              omnisciserver

I can see my conteiner-id in “restarting” state.

Hi,

I got this in the yaml files

following the instructions here

looks we have different versions between docs and docs-new.

anyway I would replace the
image: omnisci/omnisci-ee-cuda:v5.7.1
with
image: omnisci/omnisci-ee-cuda:latest

I guess you don’ìt need to install omnisci sever docker in advance, and I not sure if you can use the bare-metal install instead the container in the docker-compose file.

I will do a double check internally

After some troubleshooting using docker logs:

docker logs --tail 50 --follow --timestamps <container-id>

and editing of the yaml file (disable binary mode, and set SPAWNER_ENV_OMNISCI_PROTOCOL: http ) , I got omnisci starting and working in a docker container, and the Jupyter icon visible.

Now I’m getting

503 : Service Unavailable
Your server appears to be down. Try restarting it from the hub

whenever I open Jupyter with the upper right icon from Immerse at the following address…

http://localhost:6273/jupyter/user/admin/

JupyterLab is not active:

docker ps | grep jupyterlab

I’m wondering what to check in order to fix this: the docker containers appear to be fine:

WS:/var/lib/omnisci$ docker container ls                                      
CONTAINER ID   IMAGE                             COMMAND                  CREATED             STATUS          PORTS                                                                                                      NAMES
b0b1dfd73019   omnisci/omnisci-jupyterhub:v0.4   "/docker-entrypoint.…"   43 minutes ago      Up 32 minutes   8000/tcp                                                                                                   jupyterhub
16bcee286dae   omnisci/omnisci-ee-cuda:latest    "/bin/sh -c '/omnisc…"   About an hour ago   Up 32 minutes   0.0.0.0:6273-6274->6273-6274/tcp, :::6273-6274->6273-6274/tcp, 0.0.0.0:6278->6278/tcp, :::6278->6278/tcp   omnisciserver

Hi,
using this yml file

candido@zion-legion:/var/lib/omnisci$ cat docker-compose.yml 
version: '3.7'

services:

  omnisciserver:
    container_name: omnisciserver
    image: omnisci/omnisci-ee-cuda:latest
    restart: always
    ipc: shareable
    volumes:
      - /var/lib/omnisci:/omnisci-storage
      - /var/lib/omnisci/data/omnisci_import/jhub_omnisci_dropbox:/jhub_omnisci_dropbox
    networks:
      - omnisci-frontend
      - omnisci-backend
    ports:
      - "6273:6273"
      - "6274:6274"
      - "6278:6278"
    # If using binary encryption, uncomment the below line to override the default 
    # command that uses startomnisci, noting that you must have an existing OmniSci 
    # data directory and run initdb before making this change.
    # command: /bin/bash -c "/omnisci/bin/omnisci_web_server --config /omnisci-storage/omnisci.conf & /omnisci/bin/omnisci_server --config /omnisci-storage/omnisci.conf"


  # The purpose of this is to make sure the jlabimage is pulled because jupyterhub will not pull it automatically when launching
  jupyterlab-tmp:
    image: &jlabimage omnisci/omnisci-jupyterlab-cpu:v0.5
    command: echo
    networks:
        - omnisci-backend


  jupyterhub:
    container_name: jupyterhub
    image: omnisci/omnisci-jupyterhub:v0.4
    restart: always
    networks:
      - omnisci-backend
    depends_on:
      - omnisciserver

    volumes:
      - /var/run/docker.sock:/var/run/docker.sock

      # Map this volume if binary encryption mode is configured and certificates are being validated
      # - /var/lib/omnisci/cacerts.crt:/omnisci-storage/cacerts.crt

    environment:
      ### Required settings ###

      DOCKER_JUPYTER_LAB_IMAGE: *jlabimage

      OMNISCI_HOST: omnisciserver
      OMNISCI_JUPYTER_ROLE: omnisci_jupyter

      ### Optional settings  ###

      # DOCKER_NOTEBOOK_DIR: /home/jovyan                   # The directory inside the user's Jupyter Lab container to mount the user volume to.
      # HUB_IP: jupyterhub                                  # The hostname or IP of the Jupyter Hub server
      # JHUB_BASE_URL: /jupyter/                            # The base URL prepended to all Jupyter Hub and Lab requests
      # OMNISCI_ALLOW_SUPERUSER_ROLE: "false"               # Enable / disable admin access to Jupyter Hub
      # JLAB_CONTAINER_AUTOREMOVE: "true"                   # Enable / disable automatic removal of stopped Juptyer Lab containers
      # JLAB_DOCKER_NETWORK_NAME: omnisci-backend           # The docker network name for Jupyter Lab containers
      # JLAB_IDLE_TIMEOUT: 3600                             # Shut down Jupyter Lab containers after this many seconds of idle time
      # JLAB_NAME_PREFIX: jupyterlab                        # Container name prefix for Lab containers
      # JLAB_OMNISCI_IMPORT_VOLUME_PATH: /var/lib/omnisci/data/omnisci_import/jhub_omnisci_dropbox  # Local Docker host path for where to mount the shared directory available to the OmniSciDB server for file ingest
      # JLAB_NOTEBOOK_TERMINALS_ENBLED: "false"             # Enable terminals in notebooks
      # JLAB_USER_VOLUME_PATH: /var/lib/omnisci/jupyter/    # Local Docker host path to be used for user Jupyter Lab home directory volume mapping
      # JUPYTER_DEBUG: "true"                               # Turn on / off debugging for Jupyter Hub and Lab
      # OMNISCI_BINARY_TLS_CACERTS_LOCAL_PATH: /var/lib/omnisci/cacerts.crt # Specifying this or mapping a volume in the Hub container to /omnisci-storage/cacerts.crt will automatically enable binary TLS mode
      # OMNISCI_BINARY_TLS_VALIDATE: "false" # Whether or not to validate certificates in binary TLS mode. Specifying either "true" or "false" will enable binary TLS mode
      # OMNISCI_PORT: 6278 # Port that Jupyter Hub should use to connect to OmniSci. Ensure this matches the protocol
      # OMNISCI_PROTOCOL: http # Protocol that Jupyter Hub should use to connect to OmniSci. Ensure this is "binary" if using binary encryption
      # SPAWNER_CPU_LIMIT: 1                                # Number of CPU cores available for each Jupyter Lab container, see https://jupyterhub.readthedocs.io/en/stable/api/spawner.html#jupyterhub.spawner.Spawner.cpu_limit
      # SPAWNER_RAM_LIMIT: 10G                              # Amount of CPU RAM available for each Jupyter Lab container, see https://jupyterhub.readthedocs.io/en/stable/api/spawner.html#jupyterhub.spawner.LocalProcessSpawner.mem_limit
      # SPAWNER_ENV_OMNISCI_HOST: omnisciserver             # Hostname / IP address of the OmniSci server for Lab containers to connect to by default
      # SPAWNER_ENV_OMNISCI_PORT: 6274                      # Port of the OmniSci server for Lab containers to connect to by default
      # SPAWNER_ENV_OMNISCI_PROTOCOL: binary                # Protocol of the OmniSci server for Lab containers to connect to by default
      # OMNISCI_DB_URL: "omnisci://omnisciserver:6274/omnisci" # Alternative, direct connection (not Immerse session) to omnisciserver. Username will be inferred, but password will be required in notebook.

      # More volumes for lab containers:
      # JLAB_VOLUME_1: /data1:/data1:rw
      # JLAB_VOLUME_2: /var/lib/omnisci:/omnisci-storage:ro


networks:
  omnisci-frontend:
    driver: bridge
    name: omnisci-frontend
  omnisci-backend:
    driver: bridge
    name: omnisci-backend

so the one posted in the docs-new.omnisci.com ( that would be the same as the docs.omnisci.com, but it’s not

Anyway, this is the log on my notebook that’s running a pascal card on a ubuntu 20.04 (I don’t think the 21.04 would make us much difference)

candido@zion-legion:/var/lib/omnisci$ sudo docker run --rm nvidia/cudagl:11.0-runtime-ubuntu18.04 nvidia-smi
Unable to find image 'nvidia/cudagl:11.0-runtime-ubuntu18.04' locally
11.0-runtime-ubuntu18.04: Pulling from nvidia/cudagl
171857c49d0f: Pull complete 
419640447d26: Pull complete 
61e52f862619: Pull complete 
2a93278deddf: Pull complete 
c9f080049843: Pull complete 
8189556b2329: Pull complete 
c306a0c97a55: Pull complete 
4eeefb9caa0a: Pull complete 
8bcffc4ca3eb: Pull complete 
0306005e1055: Pull complete 
0a41ac2096c9: Pull complete 
Digest: sha256:51d9dc0790f1a6040b86f7c13f2906077afdc4a31811d1596a8522e48e98fea9
Status: Downloaded newer image for nvidia/cudagl:11.0-runtime-ubuntu18.04
Tue Oct 26 12:39:52 2021       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 460.91.03    Driver Version: 460.91.03    CUDA Version: 11.2     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  GeForce GTX 105...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   44C    P8    N/A /  N/A |    913MiB /  4042MiB |      0%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
+-----------------------------------------------------------------------------+
candido@zion-legion:/var/lib/omnisci$ sudo docker-compose pull
Pulling omnisciservePulling omnisciserver  ... done
Pulling jupyterlab-tmp ... done
Pulling jupyterhub     ... done
candido@zion-legion:/var/lib/omnisci$ docker-compose up -d
candido@zion-legion:/var/lib/omnisci$ sudo docker-compose up -d
[sudo] password for candido: 
Creating omnisciserver            ... done
Creating omnisci_jupyterlab-tmp_1 ... done
Creating jupyterhub               ... done
candido@zion-legion:/var/lib/omnisci$ sudo docker ps -a
CONTAINER ID   IMAGE                                 COMMAND                  CREATED          STATUS                     PORTS                                                                                                      NAMES
dd77ce32080c   omnisci/omnisci-jupyterhub:v0.4       "/docker-entrypoint.…"   8 seconds ago    Up 7 seconds               8000/tcp                                                                                                   jupyterhub
e2105af5a69a   omnisci/omnisci-jupyterlab-cpu:v0.5   "tini -g -- echo"        10 seconds ago   Exited (0) 9 seconds ago                                                                                                              omnisci_jupyterlab-tmp_1
4743ae4434b9   omnisci/omnisci-ee-cuda:latest        "/bin/sh -c '/omnisc…"   10 seconds ago   Up 8 seconds               0.0.0.0:6273-6274->6273-6274/tcp, :::6273-6274->6273-6274/tcp, 0.0.0.0:6278->6278/tcp, :::6278->6278/tcp   omnisciserver

The admin user cannot be used to run jupyter, because it’s not possible to grant the necessary privilege.

Please check with docker ps -a command if the omnisci-jupyterlab-cpu has been run

Thanks Candido,
I was using the admin user, therefore now I switched to a new different user (can I set the admin privileges on the new user with “is_super = ‘true’”? )

Anyway, this link:

points to: docs.omnisci.com leading to some obsolete docs, I think.

Now I’m using the same yaml file as you, and I see a omnisci-jupyterlab-cpu process in status = Exited like the one you posted.

WS:/var/lib/omnisci$ docker ps -a
CONTAINER ID   IMAGE                                 COMMAND                  CREATED          STATUS                      PORTS                     
994122bc0362   omnisci/omnisci-jupyterhub:v0.4       "/docker-entrypoint.…"   21 minutes ago   Up 21 minutes               8000/tcp                  
16bcee286dae   omnisci/omnisci-ee-cuda:latest        "/bin/sh -c '/omnisc…"   3 hours ago      Up 28 minutes               0.0.0.0:6273-6274->6273-62
2c3ad05fe7d8   omnisci/omnisci-jupyterlab-cpu:v0.5   "tini -g -- echo"        24 hours ago     Exited (0) 21 minutes ago                             

I am logged in Immerse as the new user (created with is_super = ‘true’) and switching to JupyterHub I get:

and after a while:

Hi,
you shouldn’t use a user that’s is a superuser, but for me is working.

If you want to use a user that’s not super, give the necessary grants to access to DB to the user

Hi,
I recreated the user with is_super=false, and assigned the DB permission, but I assume is not a db_user/permission related problem, here.

CREATE USER gcampana (password = '*****', is_super = 'false', default_db='omnisci');

GRANT ALL ON database omnisci to gcampana

CREATE ROLE omnisci_jupyter

GRANT omnisci_jupyter TO gcampana

After triple checking the configuration, what I get are the following containers:

WS:~/Documents$ docker ps -a
CONTAINER ID   IMAGE                                 COMMAND                  CREATED          STATUS                      PORTS                                                                                                      NAMES
dce08e0c19ab   omnisci/omnisci-jupyterhub:v0.4       "/docker-entrypoint.…"   35 minutes ago   Up 35 minutes               8000/tcp                                                                                                   jupyterhub
d4825da3086b   omnisci/omnisci-jupyterlab-cpu:v0.5   "tini -g -- echo"        3 hours ago      Exited (0) 35 minutes ago                                                                                                              omnisci_jupyterlab-tmp_1
7dab14ad699c   omnisci/omnisci-ee-cuda:latest        "/bin/sh -c '/omnisc…"   3 hours ago      Up 3 hours                  0.0.0.0:6273-6274->6273-6274/tcp, :::6273-6274->6273-6274/tcp, 0.0.0.0:6278->6278/tcp, :::6278->6278/tcp   omnisciserver

with the error 500/503 while opening Jupyter from Immerse, and this container logs:
Omnisci JupyterHub container log.txt (14.9 KB)

Into the log there are a number of rows I’m not sure how to interpret, leading to the error.

And docker is just fine:

WS:/var/lib/omnisci$ sudo systemctl status docker
[sudo] password for gcampana: 
● docker.service - Docker Application Container Engine
     Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
     Active: active (running) since Wed 2021-10-27 17:51:47 CEST; 7min ago
TriggeredBy: ● docker.socket
       Docs: https://docs.docker.com
   Main PID: 1451 (dockerd)
      Tasks: 91
     Memory: 133.0M
     CGroup: /system.slice/docker.service
             ├─1451 /usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock
             ├─1701 /usr/bin/docker-proxy -proto tcp -host-ip 0.0.0.0 -host-port 6278 -container-ip 172.19.0.2 -container-port 6278
             ├─1708 /usr/bin/docker-proxy -proto tcp -host-ip :: -host-port 6278 -container-ip 172.19.0.2 -container-port 6278
             ├─1723 /usr/bin/docker-proxy -proto tcp -host-ip 0.0.0.0 -host-port 6274 -container-ip 172.19.0.2 -container-port 6274
             ├─1730 /usr/bin/docker-proxy -proto tcp -host-ip :: -host-port 6274 -container-ip 172.19.0.2 -container-port 6274
             ├─1744 /usr/bin/docker-proxy -proto tcp -host-ip 0.0.0.0 -host-port 6273 -container-ip 172.19.0.2 -container-port 6273
             └─1751 /usr/bin/docker-proxy -proto tcp -host-ip :: -host-port 6273 -container-ip 172.19.0.2 -container-port 6273

ott 27 17:51:45 gcampana-Z10PE-D16-WS dockerd[1451]: time="2021-10-27T17:51:45.548522516+02:00" level=info msg="Default bridge (docker0) is assigned with an IP address 172.17.0.0/16. Daemon option --bip can be used to set a preferred IP address"
ott 27 17:51:45 gcampana-Z10PE-D16-WS dockerd[1451]: time="2021-10-27T17:51:45.682435482+02:00" level=info msg="No non-localhost DNS nameservers are left in resolv.conf. Using default external servers: [nameserver 8.8.8.8 nameserver 8.8.4.4]"
ott 27 17:51:45 gcampana-Z10PE-D16-WS dockerd[1451]: time="2021-10-27T17:51:45.682474452+02:00" level=info msg="IPv6 enabled; Adding default IPv6 external servers: [nameserver 2001:4860:4860::8888 nameserver 2001:4860:4860::8844]"
ott 27 17:51:45 gcampana-Z10PE-D16-WS dockerd[1451]: time="2021-10-27T17:51:45.767566139+02:00" level=info msg="No non-localhost DNS nameservers are left in resolv.conf. Using default external servers: [nameserver 8.8.8.8 nameserver 8.8.4.4]"
ott 27 17:51:45 gcampana-Z10PE-D16-WS dockerd[1451]: time="2021-10-27T17:51:45.767608279+02:00" level=info msg="IPv6 enabled; Adding default IPv6 external servers: [nameserver 2001:4860:4860::8888 nameserver 2001:4860:4860::8844]"
ott 27 17:51:47 gcampana-Z10PE-D16-WS dockerd[1451]: time="2021-10-27T17:51:47.044490109+02:00" level=info msg="Loading containers: done."
ott 27 17:51:47 gcampana-Z10PE-D16-WS dockerd[1451]: time="2021-10-27T17:51:47.114384402+02:00" level=info msg="Docker daemon" commit=e2f740d graphdriver(s)=overlay2 version=20.10.10
ott 27 17:51:47 gcampana-Z10PE-D16-WS dockerd[1451]: time="2021-10-27T17:51:47.115737888+02:00" level=info msg="Daemon has completed initialization"
ott 27 17:51:47 gcampana-Z10PE-D16-WS systemd[1]: Started Docker Application Container Engine.
ott 27 17:51:47 gcampana-Z10PE-D16-WS dockerd[1451]: time="2021-10-27T17:51:47.165166969+02:00" level=info msg="API listen on /run/docker.sock"

Hi,

this is the output I’m getting in the logs, using chrome as web browser

2021-10-27T15:04:15.363910825Z [W 2021-10-27 15:04:15.363 JupyterHub dockerspawner:757] Container not found: jupyterlab-jup
2021-10-27T15:04:32.950484321Z [I 2021-10-27 15:04:32.950 JupyterHub log:174] 302 GET /jupyter/hub/login?newnotebook=true -> /jupyter/hub/spawn (admin@172.19.0.1) 28.32ms
2021-10-27T15:04:33.003605148Z [I 2021-10-27 15:04:33.003 JupyterHub dockerspawner:784] Container 'jupyterlab-admin' is gone
2021-10-27T15:04:33.153403585Z [I 2021-10-27 15:04:33.153 JupyterHub dockerspawner:990] Created container jupyterlab-admin (id: 0446c50) from image omnisci/omnisci-jupyterlab-cpu:v0.5
2021-10-27T15:04:33.153437715Z [I 2021-10-27 15:04:33.153 JupyterHub dockerspawner:1013] Starting container jupyterlab-admin (id: 0446c50)
2021-10-27T15:04:33.965837391Z [I 2021-10-27 15:04:33.965 JupyterHub log:174] 302 GET /jupyter/hub/spawn -> /jupyter/hub/spawn-pending/admin (admin@172.19.0.1) 1012.44ms
2021-10-27T15:04:33.978230096Z [I 2021-10-27 15:04:33.978 JupyterHub pages:303] admin is pending spawn
2021-10-27T15:04:33.979527326Z [I 2021-10-27 15:04:33.979 JupyterHub log:174] 200 GET /jupyter/hub/spawn-pending/admin (admin@172.19.0.1) 10.69ms
2021-10-27T15:04:35.978292737Z [W 2021-10-27 15:04:35.977 JupyterHub _version:56] jupyterhub version 1.0.0 != jupyterhub-singleuser version 1.1.0. This could cause failure to authenticate and result in redirect loops!
2021-10-27T15:04:35.978315754Z [I 2021-10-27 15:04:35.978 JupyterHub base:810] User admin took 3.014 seconds to start
2021-10-27T15:04:35.978467342Z [I 2021-10-27 15:04:35.978 JupyterHub proxy:261] Adding user admin to proxy /jupyter/user/admin/ => http://172.19.0.4:8888
2021-10-27T15:04:35.980632947Z [I 2021-10-27 15:04:35.980 JupyterHub log:174] 200 GET /jupyter/hub/api (@172.19.0.4) 0.80ms
2021-10-27T15:04:35.981473814Z [I 2021-10-27 15:04:35.981 JupyterHub users:606] Server admin is ready
2021-10-27T15:04:35.982438085Z [I 2021-10-27 15:04:35.982 JupyterHub log:174] 200 GET /jupyter/hub/api/users/admin/server/progress (admin@172.19.0.1) 1937.95ms
2021-10-27T15:04:35.998872861Z [I 2021-10-27 15:04:35.998 JupyterHub log:174] 302 GET /jupyter/hub/spawn-pending/admin -> /jupyter/user/admin/ (admin@172.19.0.1) 10.00ms
2021-10-27T15:04:36.018252286Z [I 2021-10-27 15:04:36.018 JupyterHub log:174] 200 POST /jupyter/hub/api/users/admin/activity (admin@172.19.0.4) 28.72ms
2021-10-27T15:04:36.043426329Z [I 2021-10-27 15:04:36.043 JupyterHub log:174] 302 GET /jupyter/hub/api/oauth2/authorize?client_id=jupyterhub-user-admin&redirect_uri=%2Fjupyter%2Fuser%2Fadmin%2Foauth_callback&response_type=code&state=[secret] -> /jupyter/user/admin/oauth_callback?code=[secret]&state=[secret] (admin@172.19.0.1) 24.11ms
2021-10-27T15:04:36.083245717Z [I 2021-10-27 15:04:36.083 JupyterHub log:174] 200 POST /jupyter/hub/api/oauth2/token (admin@172.19.0.4) 33.37ms
2021-10-27T15:04:36.118494071Z [I 2021-10-27 15:04:36.118 JupyterHub log:174] 200 GET /jupyter/hub/api/authorizations/token/[secret] (admin@172.19.0.4) 32.06ms
2021-10-27T15:04:36.620389451Z [I 2021-10-27 15:04:36.620 JupyterHub log:174] 200 GET /jupyter/hub/api/authorizations/token/[secret] (admin@172.19.0.4) 27.07ms

with mozilla I’m getting some errors, while seems to work.

I’ve not idea why it’s now working on your workstation; I wuld check the notebook code to find out why it can’t span a new server for your user