Low cost way to evaluate Mapd


I am looking to just play around with Mapd. The lowest cost aws option I saw was over $600 a month. Are there any other low cost options to test this? How does the cost of deploying this on Azure compare?


@vacquah We have two cloud-based ways to evaluate MapD, or at least to try the full functionality. We can issue credits for AWS, or we have a time-bound GCP instance. Both are Enterprise edition on a single node. Let me know if either of those interest you.

If you’d like to evaluate MapD on a more powerful system, I can introduce you to someone from the sales team.



My needs are much more simpler. The community edition should be enough for me. Looking to analyze energy usage data and determine if its good to have.


So I setup an Ubuntu VM on Azure and installed MapD by following the “Ubuntu CE CPU Installation With Apt” guide.

Everything worked ok until I got to:

Connect to Immerse using a web browser connected to your host machine on port 9092. For example, http://mapd.mycompany.com:9092.

I tried the following : http://{the public ip of the vm}:9092.

Not working. Cant connect. What am I missing?


Probably you have to enable your azure vm to accept connections on port 9092 from your host.

Check the mapd_webserver is listening on 9092 port with netstat command on Ubuntu


Yes that was it. And also had to set the destination to “VirtualNetwork” of the inbound port rule. Now time to learn how to load data!


If you have data in csv format, the fastest way to load it is using copy command from mapdql, but you have to create table before.

A fast way to create the table is to get a file with a sample of your data with headers in the first line and import with “import data” from immerse interface; this would create your table; then you can get the ddl syntax with mapdql with the \d [table name] command and eventually modify the datatypes and/or the encoding to save memory and space on disk.


Now when I access the url for Immerse, I go right into it - right past the login screen. Seem like I am auto logged in? What happens if I share the dashaboard? I’d like to enforce the password.


cool feature…isn’t it? :wink:

you can chage the behaviour looking at this post on community


@vacquah i know it’s been a few months, but i’m curious to know if your experience setting up on Azure matches what we just published today?