Mapd error while setting up


/usr/local/mapd-deps/lib/ undefined reference to sk_pop_free@OPENSSL_1.0.0' /usr/local/mapd-deps/lib/ undefined reference toCRYPTO_set_dynlock_lock_callback@OPENSSL_1.0.0’
/usr/local/mapd-deps/lib/ undefined reference to SSL_get_verify_result@OPENSSL_1.0.0' /usr/local/mapd-deps/lib/ undefined reference toSSL_shutdown@OPENSSL_1.0.0’
/usr/local/mapd-deps/lib/ undefined reference to `SSL_get_peer_certificate@OPENSSL_1.0.0’
collect2: error: ld returned 1 exit status
Import/CMakeFiles/KafkaImporter.dir/build.make:108: recipe for target ‘bin/KafkaImporter’ failed
make[2]: *** [bin/KafkaImporter] Error 1
CMakeFiles/Makefile2:1354: recipe for target ‘Import/CMakeFiles/KafkaImporter.dir/all’ failed
make[1]: *** [Import/CMakeFiles/KafkaImporter.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs…
– Configuring done
– Generating done
– Build files have been written to: /home/thickstat/Downloads/mapd-core/build
[ 58%] Built target rerun_cmake
[ 84%] Built target QueryEngine
Makefile:160: recipe for target ‘all’ failed
make: *** [all] Error 2

i have error in libthrift file
can anyone please help me to solve this

[ 52%] Linking CXX executable ../bin/KafkaImporter
[ 52%] Building CXX object SampleCode/CMakeFiles/StreamInsertSimple.dir/StreamInsertSimple.cpp.o
[ 52%] Building CXX object SampleCode/CMakeFiles/StreamInsert.dir/StreamInsert.cpp.o
/usr/local/mapd-deps/lib/ undefined reference to `SSL_CTX_new@OPENSSL_1.0.0'
/usr/local/mapd-deps/lib/ undefined reference to `SSL_get_verify_mode@OPENSSL_1.0.0'
/usr/local/mapd-deps/lib/ undefined reference to `SSL_CTX_set_verify@OPENSSL_1.0.0'
/usr/local/mapd-deps/lib/ undefined reference to `CRYPTO_num_locks@OPENSSL_1.0.0'
/usr/local/mapd-deps/lib/ undefined reference to `SSL_CTX_set_default_passwd_cb_userdata@OPENSSL_1.0.0'
/usr/local/mapd-deps/lib/ undefined reference to `SSL_get_wbio@OPENSSL_1.0.0'
/usr/local/mapd-deps/lib/ undefined reference to `BIO_ctrl@OPENSSL_1.0.0'
/usr/local/mapd-deps/lib/ undefined reference to `SSL_peek@OPENSSL_1.0.0'
/usr/local/mapd-deps/lib/ undefined reference to `CRYPTO_set_dynlock_destroy_callback@OPENSSL_1.0.0'
/usr/local/mapd-deps/lib/ undefined reference to `SSL_CTX_use_certificate_chain_file@OPENSSL_1.0.0'
/usr/local/mapd-deps/lib/ undefined reference to `SSL_get_shutdown@OPENSSL_1.0.0'
/usr/local/mapd-deps/lib/ undefined reference to `SSL_CTX_free@OPENSSL_1.0.0'
/usr/local/mapd-deps/lib/ undefined reference to `ERR_get_error@OPENSSL_1.0.0'
/usr/local/mapd-deps/lib/ undefined reference to `CRYPTO_set_locking_callback@OPENSSL_1.0.0'
/usr/local/mapd-deps/lib/ undefined reference to `TLSv1_method@OPENSSL_1.0.0'
/usr/local/mapd-deps/lib/ undefined reference to `SSL_new@OPENSSL_1.0.0'

i am having this error in libthrift what should i do
how to slove this


i got struck with this for past four days dont know how to approach this
i am using " ```

and openssl 1.0.2p


I can’t reproduce, but those are all the steps I did before compiling the code

  1. I launched the located into the scripts dir of mapd-core
  2. source /usr/local/mapd-deps/
  3. mkdir build
  4. cd build
  5. cmake -DENABLE_TSAN=on -DENABLE_CUDA=off …
  6. make -j 4

in attach a log file with the steps from 2 to 6 and the result.

I had to upgrade to gcc version 6 to be able to build the latest version (I had a problem different than your anyway)mapd_build.txt (33.3 KB)


can you verify and tell versions of openssl and libboost-all-dev you are using
you can check by running
openssl version
dpkg -s libboost-dev | grep ‘Version’

i am using
OpenSSL 1.0.2p


Have you done any system updates since building the dependencies? It might be that the deps (specifically Thrift) were built with a different version than you now have installed.

Try making sure your system is completely up-to-date (sudo apt update && sudo apt upgrade), reboot, then try wiping out /usr/local/mapd-deps and run the script again.

Mapd-core compile error

okey let you know once done


i updated my ubuntu system and i restarted all my process
after 1. cmake -DENABLE_TSAN=on -DENABLE_CUDA=off …
i gave make -j 4
i got someother errormapd error.txt (20.6 KB)
i think once this solved it will be completed
i am waiting for your response



I had to install GCC 6 to overcome this compilation problem


finally it worked thanks a lot
i have taken build then what should i do
i want to add some simple functionality in mapd where and how should i start

how to load data and query
i need some for this


Hummmm… Maybe from ExtensionFunctions

I’m working mainly on jdbc driver to enhance compatibility with enterprise bi tools


how will you load data and check whether that new function is working using query
will you use http://localhost:9092 for testing
i dont know how to query using mapd-core


You can use mapdql command that’s located in bin directory, or you can connect with a graphical client using jdbc driver like squirrel sql.

with mapdql you can login on the llocal machine the run this command

mapdql -u mapd -p [your_password] --db mapd -q -t -n

For Squirrel;
If you havent a squirrel client installed download the jar for you operating system, then run the jar you downloaded to install

copy the jdbc driver that is located on your installation of mapd

scp mapd@[server address]:/opt/github-mapd/mapd-core/build/bin/mapdjdbc-4.4.0-SNAPSHOT.jar /[the path of squirrel sql]/lib

open squirrel then select driver’s tab, the + sign to add the driver

Into the classpath you would be able to located the jar with the driver

The you have to select aliases tab and add an alias to connect to your database

Now you would be table to connect to database an run your qieries.

ou could also start the web interface of your build so:

/[path to your bui]ld/bin/mapd_web_server --config /[path to your storage]/mapd.conf

The you can connect to http://[your server address]:9092 and run your queries from sql editor


how to run mapdql
i cant run mapdql in my local which is in bin directory


you can enter on directory where mapdql is installed and type ./mapdql

or you can add the directory of your build into the PATH variable

export PATH=/[the directory of your build/bin:$PATH


thanks for your reply
i was not well hence i was not able to reply soon i runned query using mapdql
ok if i want to add some simple “sum” function where should i add that function and how should i test that whether its working in mapd-core


Hi @nagulan -

If we could take a step back now that you have a working environment, what are your goals? Are you looking to define your own functions in OmniSci for custom business logic, become a more general contributor to the open-source project, something else?



Yes I want to create own custom function in mapd I need some help on how to do that


If you want to add a custom function you should start looking here

Naturally it’s not enough add a function here, because you have to modify the Java part of calcite parser


which is the main function in mapd-core
which file should i run to start debug

i want to add simple sum function and i have to check whether it is working
so in which file i should add that function and where should i call that function

i have to check that function by query