Mapd error while setting up


#42

which ide should i use in ubuntu


#43

Hi,

if you want to use an ide you can run Nsight, that’s supplied with cuda libraries

it’s located in bin dir of you cuda installation directory (tipically /usr/local/cuda-[version]/bin


#44

i have not installed cuda yet i am using clion ide i dont which is main file to run


#45

dont know which is main file to run mapd-core


#46

I’m sorry i forgot you are running on CPU mode.

Do you mean after compile? Ir’s mapd_server in bin directory


#47

hi i run mapd_server in terminal i got this error:

thickstat@nagulan:~/workspace/mapd-core/build/bin$ ./mapd_server
MapD data directory does not exist at ‘data’. Run initdb data


#48

because you have to run with all single parameters you need or you can run with the config switch only contaning an absolute path to mapd.conf file

./mapd_server --config /[you parth to mapd.conf]/mapd.conf


#49

sorry i cant understand what your are telling
can you give any example


#50

i have the mapd.conf file on /opt/mapd_storage/ direcotry

so I tun the mapd_server from the command line in this way

./mapd_server --config /opt/mapd_storage/mapd.conf

In this way, the server will start with the parameters written into the mapd.conf file

If I want to run without using the mapd.conf file disabling the watchdog

./mapd_server --data /opt/mapd_storage/data --enable-watchdog 0

Of course i have a valid mapd database inot the /opt/mapd_storage/data


#51

in which directory should i run this command:
./mapd_server --config /opt/mapd_storage/mapd.conf

in /opt/ i have mapd folder in that there is no mapd.conf file


#54

i successfully taken build
when i opened mapd in clion ide it shown a error in cmake:

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
Arrow_LIBRARY
linked by target “cmTC_c7c25” in directory /home/thickstat/PycharmProjects/mapd-core/cmake-build-debug/CMakeFiles/CMakeTmp

CMake Error at cmake/Modules/FindArrow.cmake:76 (try_compile):
Failed to configure test project build system.
Call Stack (most recent call first):
CMakeLists.txt:255 (find_package)

– Configuring incomplete, errors occurred!
See also “/home/thickstat/PycharmProjects/mapd-core/cmake-build-debug/CMakeFiles/CMakeOutput.log”.
See also “/home/thickstat/PycharmProjects/mapd-core/cmake-build-debug/CMakeFiles/CMakeError.log”.

can you please help me out in this error log


#55

if my question is not clear ping me again


#56

i have these error since long time please advice me

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
Arrow_LIBRARY
linked by target “cmTC_1d109” in directory /home/thickstat/eclipse/mapd-core/cmake-build-debug/CMakeFiles/CMakeTmp

CMake Error at cmake/Modules/FindArrow.cmake:76 (try_compile):
Failed to configure test project build system.
Call Stack (most recent call first):
CMakeLists.txt:234 (find_package)

– Configuring incomplete, errors occurred!
See also “/home/thickstat/eclipse/mapd-core/cmake-build-debug/CMakeFiles/CMakeOutput.log”.
See also “/home/thickstat/eclipse/mapd-core/cmake-build-debug/CMakeFiles/CMakeError.log”.

please can you reply something


#57

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
CUDA_CUDA_LIBRARY (ADVANCED)
linked by target “mapd_server” in directory /home/thickstat/eclipse/mapd-core
linked by target “initdb” in directory /home/thickstat/eclipse/mapd-core
linked by target “CudaMgr” in directory /home/thickstat/eclipse/mapd-core/CudaMgr
linked by target “ResultSetTest” in directory /home/thickstat/eclipse/mapd-core/Tests
linked by target “TopKTest” in directory /home/thickstat/eclipse/mapd-core/Tests
linked by target “ProfileTest” in directory /home/thickstat/eclipse/mapd-core/Tests
linked by target “DBObjectPrivilegesTest” in directory /home/thickstat/eclipse/mapd-core/Tests
linked by target “PlanTest” in directory /home/thickstat/eclipse/mapd-core/Tests
linked by target “UpdelStorageTest” in directory /home/thickstat/eclipse/mapd-core/Tests
linked by target “MapDQLCommandTest” in directory /home/thickstat/eclipse/mapd-core/Tests
linked by target “ResultSetBaselineRadixSortTest” in directory /home/thickstat/eclipse/mapd-core/Tests
linked by target “StoragePerfTest” in directory /home/thickstat/eclipse/mapd-core/Tests
linked by target “ImportTest” in directory /home/thickstat/eclipse/mapd-core/Tests
linked by target “StorageTest” in directory /home/thickstat/eclipse/mapd-core/Tests
linked by target “ExecuteTest” in directory /home/thickstat/eclipse/mapd-core/Tests
linked by target “RunQueryLoop” in directory /home/thickstat/eclipse/mapd-core/Tests

– Configuring incomplete, errors occurred!
See also “/home/thickstat/eclipse/mapd-core/cmake-build-debug/CMakeFiles/CMakeOutput.log”.
See also “/home/thickstat/eclipse/mapd-core/cmake-build-debug/CMakeFiles/CMakeError.log”.


#58

before to lauch the cmake you would:

  1. run the mapd-deps file e.g. /usr/local/mapd-deps/mapd-deps.sh
  2. define in LD_LIBRARY_PATH the part to the version of cuda libraries you are using e.g. export LD_LIBRARY_PATH=/usr/local/cuda-8.0/lib64:$LD_LIBRARY_PATH

as suggested by @randyzwitch with the latest version of mapd-core cuda libraries >8 are needed