Mapd installation thrift issue


#1

Hi there

I am installing mapd on a brand new ubuntu machine from the community cpu edition page on the omnisci website
https://www.mapd.com/docs/v4.0.0/4_ubuntu-apt-cpu-ce-recipe.html
I get to the installation stage

sudo ./install_mapd_systemd.sh

I accept the defaults offered for storage, user locations etc and then I get a very similar message to @esraa

MAPD_USER: user MapD will be run as [root]: MAPD_GROUP: group MapD will be run as [root]: MAPD_PATH: /opt/mapd MAPD_STORAGE: /var/lib/mapd MAPD_USER: root MAPD_GROUP: root Thrift: Wed Oct 24 21:40:31 2018 TSocket::open() connect() <Host: localhost Port: 39093>Connection refused Thrift: Wed Oct 24 21:40:32 2018 TSocket::open() connect() <Host: localhost Port: 39093>Connection refused Thrift: Wed Oct 24 21:40:32 2018 TSocket::open() connect() <Host: localhost Port: 39093>Connection refused

I went through the exact same process on another brand new installation of ubuntu on another machine without problems.

Is there something specific to this machine causing the problem?

Any ideas on how to resolve?

mapdql and later pymapd throw thrift errors back thereafter

michael@michaelpc:~$ $MAPD_PATH/bin/mapdql Password: Thrift: Fri Oct 26 13:29:01 2018 TSocket::open() connect() <Host: localhost Port: 9091>Connection refused Failed to open transport. Is mapd_server running?


#2

Hi @mkor. Can you please share the output of sudo systemctl status mapd_server and sudo journalctl -eu mapd_server with us? We suspect this might be a known issue that we need to document.


#3

Hi @easy
“sudo systemctl status mapd_server” at the mapdql prompt gives this

● mapd_server.service - MapD database server
Loaded: loaded (/lib/systemd/system/mapd_server.service; disabled; vendor pre
Active: inactive (dead)
lines 1-3/3 (END)

“sudo journalctl -eu mapd_server” gives
– No entries –

Is this something that can be put right?
thanks


#4

Hi @easy - any update on this question? I am prevented from going any further unless you can advise of the fix. thanks.


#5

Hi @mkor, could you try starting the server?

sudo systemctl start mapd_server
sudo systemctl start mapd_web_server

#6

Does the trick thanks Andrew!
I didn’t have to do that before? The mapdql sample query (flights) just worked.
But hey - I know what to do now, cheers