Mapd runing error about gpu ?


#1

When the “select” statement is executed, system throw a error

> F0117 14:56:43.031839  7564 NvidiaKernel.cpp:71] Check failed: cuLinkAddFile_v2(link_state, CU_JIT_INPUT_LIBRARY, gpu_rt_path.c_str(), num_options, &option_keys[0], &option_values[0]) == CUDA_SUCCESS (999 vs. 0) 
> *** Check failure stack trace: ***
> mapd_server: ./../folly/SharedMutex.h:284: folly::SharedMutexImpl<ReaderPriority, Tag_, Atom, BlockImmediately>::~SharedMutexImpl() [with bool ReaderPriority = false; Tag_ = void; Atom = std::atomic; bool BlockImmediately = false]: Assertion `(state & ~(kWaitingAny | kMayDefer)) == 0' failed.
> WARNING: Logging before InitGoogleLogging() is written to STDERR
> I0117 14:56:43.046531  7564 MapDServer.cpp:102] Interrupt signal (6) received.
> F0117 14:56:43.046555  7564 utilities.cc:337] Check failed: IsGoogleLoggingInitialized() You called ShutdownGoogleLogging() without calling InitGoogleLogging() first!
> *** Check failure stack trace: ***
> Segmentation fault (core dumped)

I tried to reinstall the gpu driver and cuda environment, but still could not solve the problem.Who can tell the reason of this problem?Thank you very much.


#2

Hi @tianhz,

Please provide additional details on your environment - OS, OmniSci version, output from nvidia-smi. Also, details on the query your are trying to run.

Regards,
Veda


#3

hi @veda.shankar
OS version:CentOS Linux release 7.0.1406 (Core) 3.10.0-123.el7.x86_64
nvidia-smi:Tesla P4 NVIDIA-SMI 384.111
MAPD:4.2.0
Executing any select statement throws an error.


#4

Hi @tianhz,

Your software stack even though it meets OmniSci’s minimum requirements should be updated to the latest. If the problem still persists then we can get more info to debug the issue.

Regards,
Veda