Multiple install related issues with omniscience-datascience on Mac

Not sure what is up with the packaging of omniscience-datascience for mac. It seems a mess.

Is there documentation on what versions of macOS this is supposed to be supported on maybe that should be on the download page.

The current binary is not notarized by Apple, so wont install on Catalina or Big Sur, hopefully users know how to work around it… but that would be better to document.

The option to install omniscience-datascience for all users won’t work on Catalina or later due to write protected system volumes. And this will mean that the default install fails. Users may not realized they can work around this by installing for their single user. The kind of thing, and more, really ought to be documented

I can’t find doc about how to uninstall omniscience-datascience where does that live?

And if you try to install omniscience-datascience over an exisitng install you get an installer “instaltion failed” error with a popup that says

"omniscience-datascience is already installed in /Users//omniscience-datascience. Use ‘conda update omniscience-datascience’ to update omniscience-datascience.

(Yikes, go on say “omniscience-datascience” one more time in that dialog panel, I double dare you :slight_smile: ).

And then if I try that… bzzt.

% conda update omnisci-datascience

PackageNotInstalledError: Package is not installed in prefix.
prefix: /Users/darryl/omnisci-datascience
package name: omnisci-datascience