Servers.json in Docker?

Ultimately, I’m trying to enable "ui/enable_linked_zoom": true in my minimal Omnisci Immerse.

I’m running Omni via docker on Ubuntu:

sudo docker run --runtime=nvidia -d --runtime=nvidia -v /var/lib/omnisci:/omnisci-storage -p 6273-6280:6273-6280 omnisci/omnisci-ee-cuda:v5.6.0

This works great. When trying to customize via servers.json, I’m attempting to refer to it via omnisci.conf as so:

trivial-loop-join-threshold=20000
enable-watchdog=false
servers-json="/omnisci-storage/servers.json"

And the contents of servers.json are:
[
{
“feature_flags”: {
“ui/enable_linked_zoom”: true
}
}
]

I know that omnisci.conf is operational b/c of the trivial-loop parameter.

When I attempt to docker run, the system fails (silently, as far as I can tell). If I comment out the servers-json line in omnisci.conf, the server comes up fine (w/o the linked zooming).

Help?

Hi

Have you tried to put the server-Jason parameter into the [web] section of the omniscient.conf configuration file.

Something like this

port = 6274
http-port = 6278
data = “/var/lib/omnisci/data”
null-div-by-zero = true

[web]
port = 6273
frontend = “/opt/omnisci/frontend”
servers-json = “/var/lib/omnisci/servers.json”
enable-https = true

Regards,
Candido

That was exactly it - put it in the [web] section.

Note that since I’m running inside of docker, I had to use the images path to servers.json.

thanks!

Hi @schnee,

I’m sorry if I haven’t used the right paths, but I was on the phone and it’s not easy to edit things like paths and I preferred to maintain the original ones.

I’m happy you have everything working right now

Regards,
Candido