Timeout while querying


#1

Is there any options to add timeout explicitly in mapd? I need to quit the query processing if it takes longer time.


#2

Hi @nagulan,

The default server configuration allows all operations to be performed by the GPU only, and will timeout as the watchdog is enabled. Default config is:
enable-watchdog = true
enable-cpu-retry = false

Regards,
Veda


#3

Hi @nagulan,

Do your queries hang and don’t return? Where does it happen, CPU? GPU?
Or you just want to set a time budget for each query?

You could try the [experimental] dynamic watchdog feature. Add this to config file:
enable-dynamic-watchdog = true
The default time budget is 10000 ms. Queries taking longer than 10 seconds should be interrupted.
You can override the default with the following option, this for example will lower the budget to 5 seconds:
dynamic-watchdog-time-limit = 5000

Let us know if it works for you or if you run into any issues.