Timestamp with Millisecond Resolution


#1

Hi there,

I’m testing out OmnisSci and find the speed truly amazing (coming from InfluxDB). However, I need at least milliseconds timestamp resolution for our data. Now one option would be to use bigints but I read here that you do support timestamps up to nanoseconds resolution. If this is actually true, how do I use that functionality, I always seem to end up with second resolution timestamps even if the original ones have a higher precision (Core version 4.4.2)? If it is possible could someone show how to import such timestamps (e.g. with a csv pymapd) correctly and how to export them likewise?


#2

I think that the high precision timestamp has been disabled for whatever reason 4, so you have to use an older version of mapd like the 4.1.1 (but it’s not workiing so well with hp timestamps at least from mapdql) or you could try to build from github source enabling the high precision for timestamps.

on 4.4.2 if you try to create a table with a ts with precision hingher than 0 (seconds) it will return an error, this is the reason because even if you insert a value with milliseconds, microseconds the date part execeeding seconds will be truncated


#3

Hi @digitalcats,

@aznable is correct, high precision timestamps are not currently supported. We had some support initially but ran into issues with Calcite truncating our timestamps (Calcite only supports milliseconds, and we were seeing issues with microseconds and nanoseconds being truncated).

We hope to roll out support for milliseconds (and likely micro and nano) over the next few release cycles. Keep an eye on our release notes page: https://www.omnisci.com/docs/latest/7_0_release.html

Alex