Trouble with omnisci-ee-gpu-byol-5.5.3 AMI on AWS

Hello,

I wanted to try out the new Free edition of OmniSci on an AWS instance, so (as per the ‘getting started’ guide), I subscribed to omnisci-ee-gpu-byol-5.5.3 and created a new p2.xlarge instance with it. The AWS instance is running, but I’m not sure the Omnisci setup was successful:

  • I can’t access Immerse through the browser (I guess by default it’s supposed to run on port 6273 no?)
  • /opt/omnisci is not present (but /var/lib/omnisci/omnisci_storage is)
  • I can’t find $OMNISCI_PATH
  • omnisci_server.service is not found. omnisci.service is present, but dead (should it be?)
[centos@ip-XXX-XX-XX-XXX ~]$ sudo systemctl status omnisci
● omnisci.service
   Loaded: loaded (/usr/lib/systemd/system/omnisci.service; disabled; vendor preset: disabled)
   Active: inactive (dead)

Mar 17 12:37:45 ip-XXX-XX-XX-XXX.ec2.internal systemd[1]: [/usr/lib/systemd/system/omnisci.service:1] Assignment outside of section. Ignoring.
Mar 17 12:37:45 ip-XXX-XX-XX-XXX.ec2.internal systemd[1]: [/usr/lib/systemd/system/omnisci.service:2] Assignment outside of section. Ignoring.
Mar 17 12:37:45 ip-XXX-XX-XX-XXX.ec2.internal systemd[1]: [/usr/lib/systemd/system/omnisci.service:3] Assignment outside of section. Ignoring.

Did I do something wrong, or is there a problem with the AMI?

Hi @jmboehm,

It looks like that in the AMI is installed a docker version of omnisci; I started with the usual syntax

[centos@ip-172-31-24-0 var]$ sudo docker run --runtime=nvidia -v $HOME/omnisci-docker-storage:/omnisci-storage -p 6273-6280:6273-6280 omnisci/omnisci-ee-cuda:latest

startomnisci 7 running
WARN: config file does not exist, ignoring: --config /omnisci-storage/omnisci.conf
Backend TCP:  localhost:6274
Backend HTTP: localhost:6278
Frontend Web: localhost:6273
Calcite TCP:  localhost:6279
- omnisci_server 112 started
- omnisci_web_server 113 started
⇨ http server started on [::]:6273
Navigate to: http://localhost:6273

I used my free license, and it’s working.

While the usage instructions give me the idea that a binary version of the software would be installed, you can, if you want, run with docker; in the meantime, I will ask internally if there a problem with the AMI or in the documentation.

Regards,
Candido

1 Like

Hi @jmboehm,

I asked internally and while the AMI is intended to be a docker one (that’s because to run the jupyter notebook extension it’s needed to use the docker), there are obviously issues on the AMI, so our dev-ops are looking into the issue, and we will update it ASAP.

I want to thank you for your patience and for reporting the problem to us.

Candido

1 Like

Hi @jmboehm

the problem as been isolated; it’s a script that for whatever reason isn’t starting when at the creation time of the AWS instance.

as a workaround, I can suggest running this command with root privilege

/home/mapd/cloud-init/run-once.sh

this way you should get the complete experience.

Thanks again for reporting problem, and have fun with Omnisci Free edition

Confirmed; running the script solves the problem. Thank you for your fast and competent response.

Well the most competent response come up from Pete Antosik :sunglasses:

Mine was half-competent, anyway, we are in the process to release a better version that resolves some annoying bugs. I will reach you here when will be GA. We are on RC stage yet.

Hi Candido,

Sorry to bother you again. I’ve terminated the old AWS instance to make use of the new AMI, and created a new instance from the new AMI. However, when pasting the license key, I now get a “License error: Failed to parse key”.

  • Is that expected? Do licenses for Omnisci Free only apply to one AWS instance, even if the old one has been terminated?
  • If yes, is it possible to “free” a license to move it to another instance?
  • If no, any idea what’s going on? :slight_smile:

Many thanks, as always.

Best, Johannes

Hi Johannes,

Don’t worry, you are not bothering me at all. I am here to help and be helped by the community.

AFAIK you can use the key more than once (how we could check…we are not Skynet… Luckily…Unluckily don’t know :thinking:)

We faced that error when applied to OmniSci version older than 5.5.3…so if you are running a 5.5.2 you can use the free license (because the software isnt is aware of it).

So the question is… Which version are you running (please tell me it’s older than 5.5.3…you can also lie… Kidding).

If you are on an older version you have to upgrade.

Best,
Candido

You’re absolutely right, the AMI is on 5.5.2 (but it used to be 5.5.3 already, no? maybe it was removed). No worries, I’ll wait until 5.5.3 is out on the AMI.

Phew! :wink:

Hi

The 5.5.3 has been removed because of a bug, the 5.5.6 has been finalized yesterday and would be on AWS AMI today or tomorrow.

Candido

1 Like